images rotating upon upload

1 month 4 weeks ago #10804 by mjkahn
I love the intuitive nature of this plugin. I do have a couple of issues. the first time I used it I uploaded a couple of hundred images. Most loaded into the thumbnails and images as expected. A few loaded in a rotated position, some 90° counterclockwise and a few rotated 180°. When I checked the originals, they are all facing as expected. I uploaded the problem images again and they still rotated. How can I get these images to display correctly? Is there a way to return them to their appropriate position from within Joomla?

thanks,

Mitch

1 month 4 weeks ago #10806 by Vitja
Hi Mitch,

first of all, thank you for activating the Support subscription.

It's the first time that this issues was reported. Can you please send me link to a demo gallery where I can see the problem? If possible, could you please send me one of those images via email (see Contact for address) so that I can analyze it in my development environment?

Thank you in advance!

Cheers

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
1 month 4 weeks ago #10808 by mjkahn
Thank you for the quick response.

On the following page in the fourth row, the fourth and fifth images (from the left) are rotated 90° counterclockwise. On the third row from the bottom the center photo is upside down.

The site is on our development server, but we are hoping to go live in 24 hours:
cherokees2osh.engine-thunderbird.com/index.php/photo-album/2017

I will send you one of the photos. Let me know if you would like more.

thanks again.

Also, is there a way to turn off the photo name on the top of the window that opens when you click on a thumbnail? I can't seem to find a setting for that.
1 month 4 weeks ago #10809 by Vitja
Hi Mitch,

I've just checked the gallery and the images. The images are displayed properly in your image program using the stored Orientation tag in the EXIF data.



But the image resizer function in SIGE does not use this information (just like the Joomla! Media Manager - see screenshot), thus those images are not aligned properly. On the following screenshot you will see the thumbnail from the image that I've uploaded directly via the Media Manager. It has the same incorrect orientation:



Fast workaround:

Open the image with an image program and create a copy of the original image (simply by saving it with a new name). The image should then be orientated properly in SIGE (or the Media Manager in general).

This issue can be solved automatically by reading the EXIF data in the thumbnail creation process. I will put it on my todo list.

I've answered your question regarding the image names in the JS view in the other thread! :-)

Have success!

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
Attachments:
The following user(s) said Thank You: mjkahn
Time to create page: 0.164 seconds