Spoiler und e-mail Adressen

2 years 11 months ago #9315 by Franz A.
Hallo,

ich benötige ein Lösung um gewisse Teile einer Seite (Mail-Adressen, Handy-Nr.,...) auszublenden und nur registrierten Usern zur Verfügung zu stellen. Dies muss auch innerhalb einer Tabelle funktionieren, weshalb ich hier auch nicht die "read more after Login..." Geschichte verwenden kann.

Das EJS Plugin scheint hier die Lösung zu sein. Einfach und gut.

Leider funktioniert es nicht mehr sobald eine Mail-Adresse innerhalb des Spoilers verwendet wird.
Dann wird die ganze Seite nicht mehr angezeigt (nur noch die Kopfzeile).
Auch dann nicht wenn ich {emailcloak=off} auf der Seite verwende.
Sobald ein @ Zeichen drin ist geht es nicht mehr.
Gerade die Mailadressen sind aber hier der entscheidende Teil und der Grund dafür daß ich EJS hier einsetzen will.
Gibt es dafür eine Lösung ?

Ausserdem wollte ich fragen ob man den Text "Nur für registrierte Besucher. Bitte einloggen!" irgendwo ändern kann.

Ich verwende Joomla 3.3.1 und das Astoria Pro Template.

Danke im voraus.

2 years 11 months ago - 2 years 11 months ago #9317 by Vitja
Hallo Franz,

danke für die Anfrage.

Für dein Vorhaben wird sich wohl eher ein anderes Plugin mehr eignen: joomla-extensions.kubik-rubik.de/de/down...restriction/joomla-3

Bitte teste Easy Content Restriction, das habe ich für solche Anwendungsfälle geschrieben.

Viele Grüße

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
2 years 11 months ago #9318 by Franz A.
vielen Dank für die schnelle Antwort.

Leider habe ich aber auch beim ECR das selbe Problem: sobald ich ein @ Zeichen innerhalb der [ecr] [/ecr] verwende bleibt die ganze Seite leer. Mit jedem anderen Text (selbst mit ganzen Tabellen innerhalb) funktioniert es tadellos.

Habe nur ich das Problem ?
Kann das was mit meinem Template zu tun haben ?
2 years 11 months ago #9321 by Vitja
Hallo Franz,

hast du die E-Mail Verschleierungsfunktion aktiviert? Deaktiviere das Cloakingplugin mal und teste es erneut.

Gruß

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
2 years 11 months ago - 2 years 11 months ago #9322 by Franz A.
Hi

anfangs habe ich es mit {emailcloak=off} versucht, nun aber sogar das ganze Plugin deaktiviert.

Der Text im Editor ist wie folgt:
[ecr]Das ist der verborgener Test-Text - nur für registrierte User ! webmaster@yyy-xxx.de [/ecr]
als Quelltext kommt dann an:

<!-- COMPONENT -->
<div class="item-page" itemscope itemtype=" schema.org/Article ">
<meta itemprop="inLanguage" content="de-DE" />
<div class="page-header">
<h2 itemprop="name">
<a href="/index.php/facebook" itemprop="url"> Facebook Like</a>
</h2>
</div>
<div class="icons">
</div>
<div itemprop="articleBody">
</div>
</div>
<!-- //COMPONENT -->


wenn ich das @ durch ein Q ersetze:
...
<div itemprop="articleBody">
<p><span style="font-weight: bold; text-align: center;"><span style="font-weight: bold; text-align: center;">Das ist der verborgener Test-Text - nur für registrierte User ! webmasterQkfv-mue.de</span></span></p>
</div>
...

und wenn ich das [ecr] weglasse:
...
<div itemprop="articleBody">
<p><span style="font-weight: bold; text-align: center;"><span style="font-weight: bold; text-align: center;">Das ist der verborgener Test-Text - nur für registrierte User ! <a href="This email address is being protected from spambots. You need JavaScript enabled to view it. ">This email address is being protected from spambots. You need JavaScript enabled to view it.</a> </span></span></p>
</div>
...

egal wie ich es anstelle, ich kriege keine gültige Mailadresse in den [ecr]-Teil.
2 years 11 months ago #9328 by Vitja
Hallo Franz,

danke für detaillierte Beschreibung.

Ich schaue es mir selber mal an und versuche, einen Workaround zu finden.

Ich melde mich noch mal hier!

Gruß

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
2 years 11 months ago - 2 years 11 months ago #9329 by Vitja
Ah, ich hatte vergessen, dass ich das @-Zeichen als Delimiter einsetze, dieses jedoch nicht zusätzlich maskiert habe.

Öffne die Datei: plugins/content/easycontentrestriction/easycontentrestriction.php

und ändere die Zeile 165 um in

$article->text = preg_replace('@'.preg_quote($match[0], '@').'@sU', $replacement_text, $article->text);

und die Zeile 169 um in

$article->text = preg_replace('@'.preg_quote($match[0], '@').'@sU', $match[2], $article->text);

Dann kannst du auch das @-Zeichen ganz normal verwenden!

Gruß

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
The following user(s) said Thank You: Franz A.
2 years 11 months ago #9330 by Franz A.
Danke - du bist mein Held !

passt alles wieder :)
2 years 11 months ago #9331 by Vitja
Gern geschehen!

Habe diese Änderung nun auch offiziell im neuen Release eingebaut ( joomla-extensions.kubik-rubik.de/downloa...-content-restriction ).

Viel Erfolg mit meinen Erweiterungen!

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
Time to create page: 0.121 seconds