Schatten fehlt um Thumbnails / PHP Memory Limit

5 years 10 months ago #4773 by benjicux
Hallo liebes Support-Team,

das Plugin ist wirklich sehr schön und einfach anzuwenden. Ich habe zwar noch ein paar Probleme
mit dem PHP-Memory Limit wenn ich mehrere Galerien verwende, aber es sieht gut aus.

Ich habe das Forum bezüglich der Thumbail Darstellung schon studiert und die
Option !important schon gefunden, was bspw. das Padding rund um das Thumbnail
angeht. Das läuft gut.

Leider zeigt sich der Schatten nicht um die Thumbanils.

Die Seite läuft auf www.ihrraumausstattermeister.de

Unter Polstermanufaktur findet sich eine Einbindung des Plugins direkt
im Artikel.
Der weiße Rahmen ist um das Thumbnail, aber leider nicht der Schatten.
Kann das mit dem Template der Seite zusammenhängen ?

Oder ist die Angabe zu dem Shadow.... PNG bei Suchmaschinenfreundlichen URLs
ein Problem ?


Darüber hinaus habe ich eine Gallerie angelegt unter Polstermanufaktur. Das läuft gut.
Nun wollte ich ein weiteres Unterverzeichnis unter Bodenbeläge anlegen. Wenn ich hier
aber mehr als 4 Bilder einbinde kommt immer ein PHP-Fehler mit "Memory exhausted".

Welches Problem liegt denn hier evlt. vor bzw. wo liegt hier der Zusammenhang mit dem
PHP-Memory Limit ? Hat das nur mit Thumbnails zu tun oder geht es um die Menge an
Bildern überhaupt ?


Würde mich über ein Feedback freuen.

Viele Grüße
Benjamin Busch

5 years 10 months ago #4777 by Vitja
Hallo Benjamin,

danke für das Interesse an SIGE.

Jede erneute Umwandlung der Originalbilder ist teuer. Wenn du das bei jedem Laden erneut durchführen lässt, dann wird entsprechend viel Speicher benötigt. Wichtig ist, das die Option "Thumbnails speichern" gesetzt ist und die Option "Überschreiben" deaktiviert ist.

Je größer die Bilder sind, desto rechenintensiver ist der Vorgang. Du solltest die Originalbilder schon offline mit einem Bildbearbeitungsprogramm verkleinern und die Bilder nicht in Originalgröße hochladen.

Du kannst den Memory Limit meistens auch hochsetzen lassen. Frag am besten deinen Hoster danach!

Was den Schatten angeht:

Es spielt keine Rolle, ob SEF URLs aktiv sind. Schau mal die Bilder mit dem Firebug an. Bei dir überschreibt die Template CSS fast alle Anweisungen des Plugins. Du müsstest die CSS des Templates anpassen oder vielleicht könnte der Trick klappen: einfach überall in der CSS der SIGE ein !important einfügen.

Viel Erfolg!

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
5 years 9 months ago #4800 by benjicux
Hallo Vitja,

vielen Dank für die Rückmeldung. Ich habe heute Abend noch etwas rumexperminetiert.
Die Option mit dem Überschreiben habe ich rausgenommen. Ich dachte, man braucht das für die
ersten Thumbs, aber das geht ja so. Die Bilder hab ich noch weiter verkleinert, das passt
dann jetzt sehr gut soweit.

Der Tipp mit den weiteren !important tags war Gold wert. Habe mich da rangesetzt und eine
Variable Deines CSS s nach der anderen editiert. Ich kannte das auch noch gar nicht, dass dieser
!important-Code das übersteuert. Sieht jetzt sehr gut aus soweit.

Eine letzte Frage hätte ich allerdings dann doch noch.
Ich habe jede Gallery der Seite (habe die Bilder nun in mehrere Galleries unterteilt) mit den
gleichen Variablen versehen, vor allem width=100,height=100

Bei Polstermanufaktur sind die Abstände auch super und vernünftig und verhältnismäßig.
Bei Bodenbeläge sind die Abstände aber sehr weit auseinander von Zeile zu Zeile
trotz der gleichen Parameter.

Hast Du da noch eine Idee ?

Vielen Dank und viele Grüße
Benjamin
5 years 9 months ago #4808 by Vitja
Hallo Benjamin,

du könntest die Abstände mittels dem gap-Parametern anpassen. Dort sind zum Beispiel auch negative Werte möglich. Schau einfach in die Parameterliste, wie die Befehle genau lauten.

Viel Erfolg!

Kubik-Rubik Joomla! Extensions

Please support my work with a review in the Joomla! Extensions Directory: extensions.joomla.org/profile/profile/details/61997
5 years 9 months ago #4811 by benjicux
Hallo nochmal,

ich hab noch etwas herumprobiert. Es lag im Endeffekt an den Seitenverhältnissen. Nachdem ich den ratio=0 Parameter
verwendet habe, läuft es nun rund und wunderbar.

Herzlichen Dank noch mal für den Support und

viele Grüße
Benjamin
Time to create page: 0.123 seconds